AmazonからECS 3.0からECS 4.0へと移行するよう促すメールが届いた。

We are writing to remind you that the Amazon E-Commerce Web Service 3.0 will be deprecated on March 31st, 2008. Our monitoring indicates that you are still using Amazon E-Commerce Service 3.0. After March 31st, 2008, we will no longer accept Amazon ECS 3.0 requests. Please upgrade to the Amazon Associates Web Service (previously called Amazon E-Commerce Web Service 4.0) by then to ensure that you or your customers are not affected by the deprecation.

Amazonアソシエイトは全然売れてないのだが、レビュー記事を書くときなどに商品の画像をアップロードする手間が省けるのでISBN変換プラグインは大変重宝している。しかし3月31日以降、ECS 3.0は受け付けないということなので、ISBN変換プラグインをECS 4.0に対応させなければならない。

Migration Guideを読みながらここ数日試行錯誤しているのだけど、全然うまく行かない。こういうときにPHPをdisrespectできるくらいプログラミングスキルがあれば良いのにとつくづく思う。

コメント


(オプション)

(オプション)